Author Topic: new owner of 2001 156 selespeed  (Read 1345 times)

0 Members and 1 Guest are viewing this topic.

ccaltabiano86

  • Newbie
  • *
  • Posts: 22
new owner of 2001 156 selespeed
« on: December 06, 2011, 08:53:48 AM »
Hi guys,
recently bought myself a 156 selespeed.
in pretty good condition with 111,000 km.
I got it really cheap off a family friend, but have had a gearbox problem after car was involed in an accident a few weeks ago.
Damage was minor, but gearbox will not go into gear anymore.
I have searched the forum and most people are mentioning a pump for the gearbox?
any idea what current prices are to replace pump? (post from 2009 said $1,000)
I really want to try and keep this car for a long time, and would like some advise on what other people have done to fix gearbox issues.
Are there any aftermarket (better) replacements, or gearbox upgrades avaliable?

Thanks,
Chris
Finally bought an Alfa :)

and all the problems that come with it!

dehne

  • Hero Member
  • *****
  • Posts: 1659
Re: new owner of 2001 156 selespeed
« Reply #1 on: December 06, 2011, 09:55:40 AM »
$300 for the pump on an exchange from bruno at maranello's,
but first make sure there is power getting to the pump first, as it could be a fuse that has blown or disloged
now
1x 85 mdl road 90
2013 Giulietta 1.4
2015 Launch Edition Giulietta
Past
Multiple Alfa 90’s, Alfetta’s and 147’s

colcol

  • Hero Member
  • *****
  • Posts: 4064
  • AROCA Member #: 1201
Re: new owner of 2001 156 selespeed
« Reply #2 on: December 06, 2011, 08:35:12 PM »
As Dehne suggested, see if pump is running, when you get in car and open door, you should hear pump running to build up pressure, before starting car, if you can't get it going, take it to an Alfa specialist, as they work on these all the time, and i am sure they have had this problem before, see Maranello Pursang Motors, Maceuri Motors or Monza Motors, don't despair, it could be only a sensor, the drivers who have Selespeeds love them, Colin.
1974 VW Passat [ist car] 1984 Alfa 33TI [daily driver] 2002 Alfa 156 JTS [daily driver]

dehne

  • Hero Member
  • *****
  • Posts: 1659
Re: new owner of 2001 156 selespeed
« Reply #3 on: December 06, 2011, 11:26:27 PM »
sometimes by opening the door the pump does not start so what i would do is use a volt meter and check it that way, if you turn the ignition on but dont start the car it should send the current through or alternativly get help when doing it
now
1x 85 mdl road 90
2013 Giulietta 1.4
2015 Launch Edition Giulietta
Past
Multiple Alfa 90’s, Alfetta’s and 147’s

ccaltabiano86

  • Newbie
  • *
  • Posts: 22
Re: new owner of 2001 156 selespeed
« Reply #4 on: December 09, 2011, 06:49:18 AM »
Thanks guys,
All the help is much appreciated :)
Will check everything out over the weekend and try to get it to a specialist.

Regards,
Christian.
Finally bought an Alfa :)

and all the problems that come with it!