Author Topic: 2009 2.2 not firing up.  (Read 2244 times)

0 Members and 1 Guest are viewing this topic.

Alfatango

  • Jr. Member
  • **
  • Posts: 86
Re: 2009 2.2 not firing up.
« Reply #30 on: April 08, 2021, 11:48:52 PM »
Great to hear its sorted. From working on my previous GTs, I found the fault codes to be completely useless and now I take it to an Alfa mechanic as you spend way too much time chasing things that aren't the right thing.
159 3.2 JTS TI

Previous 2x GTs

OzzyAlfa159ti

  • Jr. Member
  • **
  • Posts: 63
Re: 2009 2.2 not firing up.
« Reply #31 on: April 09, 2021, 08:31:56 AM »
Hi Alfatango

Thank you for your reply

Crossed fingers it is now sorted
Funny thing is none of the codes pointed to spark plugs.

The car started first go after days if chasing fault codes.

After speaking to a alfa mechanic he said that not to use 98 petrol but to use 95 because it fouls the plugs and tarnishes the ends.

Infact they where really bad and had worn out the middle of the plugs.
Also the gap due to wear was huge.

He told us that the codes drive none alfa mechanics crazy and because when the car cranks but doesn't fire up it weakens the battery and triggers all sorts of codes not related to the issue and they keep replacing parts that are not the issue to why it won't start.
Especially 2.2

Hope this is the case and helps others

Kind regards
Maria

OzzyAlfa159ti

  • Jr. Member
  • **
  • Posts: 63
Re: 2009 2.2 not firing up.
« Reply #32 on: April 30, 2021, 03:30:41 PM »
UPDATE
so after a few weeks of using 95 fuel and seeing if it truly was the 98 fuel causing the issue, and happy to say that it was 98 causing all the problems.

Running perfect on 95

SeleMatt

  • Jr. Member
  • **
  • Posts: 99
Re: 2009 2.2 not firing up.
« Reply #33 on: June 03, 2021, 02:41:05 PM »
Another thing you should check is the air intake bellows for cracks/holes. My car would never start first stab of the button on 98 and so I changed to 95 where, as you say, it would then always start. It was after this that I discovered the hole in the bellows and so after fitting a new one, I tried 98 again and it now always starts first stab.

Alfatango

  • Jr. Member
  • **
  • Posts: 86
Re: 2009 2.2 not firing up.
« Reply #34 on: June 03, 2021, 07:04:55 PM »
Is that the air intake hose pipe? How would that make a difference at stand still when no air is being sucked in?
159 3.2 JTS TI

Previous 2x GTs

OzzyAlfa159ti

  • Jr. Member
  • **
  • Posts: 63
Re: 2009 2.2 not firing up.
« Reply #35 on: June 10, 2021, 08:49:24 PM »
Hi thanks for that . Will check when my partner services the car

Makes sense as air is still getting drawn in and probably effecting the air flow meter