Author Topic: Problems with la mia Giuietta  (Read 4745 times)

0 Members and 1 Guest are viewing this topic.

Giulietta Mike

  • Newbie
  • *
  • Posts: 6
Problems with la mia Giuietta
« on: March 26, 2012, 10:29:21 AM »
Hi Everyone!

I'm finally the proud owner of Giulietta. Unfortunately Ive developed a couple of annoying niggles. Would anyone be able to shed some light on them? Here's a short list:

1. There is a weird bang downshifting from 3rd to 2nd.
2. The turbo boost falls of steeply after 3000rpm
3. Sixth gear is really hard to put in sometimes after overtaking on a freeway in 5th.
4. The aluminium pedal cover for the clutch has fallen off, I don't know how to put it back on.

I will be going to the dealer later this week, so any thoughts from you guys?

I look forward to being an active member of the club!

Also, How would I be able to put up pics of my Giulietta on the forum?

Evan Bottcher

  • Administrator
  • Hero Member
  • *****
  • Posts: 2949
    • Slow and Fun - my Alfa journal
  • AROCA Member #: 2928
Re: Problems with la mia Giuietta
« Reply #1 on: March 26, 2012, 10:59:38 AM »
I can help a little with the question about attaching images - there's a little guide here: http://www.alfaclubvic.org.au/forum/index.php?topic=55.0

and if you have difficulty, give me a shout via PM.

Welcome!
Newest to oldest:
 '13 Alfa Mito QV
 '77 Alfasud Ti
 '74 Alfasud Sedan
 '68 1750 GTV
--> Slow and Fun - my Alfa journal

ANG156

  • Sr. Member
  • ****
  • Posts: 346
Re: Problems with la mia Giuietta
« Reply #2 on: March 26, 2012, 08:48:11 PM »
What giulietta is this? QV or 1.4multiair manual or TCT?

The turbo boost falling off seems strange, could only need a software upgrade in the engine ecu.

Alfa 159 autos had a weird bang while changine gears. Again a software upgrade was all the was needed.

Pedal cover falling off is not really a big deal. At least your actual pedal is there. Never forget the time the clutch pedal broke free in my sisters vw polo. Now that was scary- had to drive all the way home in second gear.
« Last Edit: March 26, 2012, 08:52:10 PM by ANG156 »

Giulietta Mike

  • Newbie
  • *
  • Posts: 6
Re: Problems with la mia Giuietta
« Reply #3 on: March 27, 2012, 09:02:41 AM »
My Giulietta is a QV without any options ticked. I will take her to the dealer next week to get everything checked out. The car literally stops pulling above 3000rpm. The revs rise but the turbo almost switches off!

colcol

  • Hero Member
  • *****
  • Posts: 4064
  • AROCA Member #: 1201
Re: Problems with la mia Giuietta
« Reply #4 on: March 27, 2012, 10:00:52 PM »
Hey Mike, what state do you and your car hail from?, Colin.
1974 VW Passat [ist car] 1984 Alfa 33TI [daily driver] 2002 Alfa 156 JTS [daily driver]

Giulietta Mike

  • Newbie
  • *
  • Posts: 6
Re: Problems with la mia Giuietta
« Reply #5 on: March 28, 2012, 12:39:28 PM »
We hail from Victoria!

colcol

  • Hero Member
  • *****
  • Posts: 4064
  • AROCA Member #: 1201
Re: Problems with la mia Giuietta
« Reply #6 on: March 28, 2012, 09:59:50 PM »
We have a new model technical night on Friday 25th May at ZAGAME Automotive in West Melbourne, all Alfa Romeo club members welcome, Colin.
1974 VW Passat [ist car] 1984 Alfa 33TI [daily driver] 2002 Alfa 156 JTS [daily driver]