Author Topic: Gulietta Rear Wiper  (Read 886 times)

0 Members and 1 Guest are viewing this topic.

J_2019

  • Newbie
  • *
  • Posts: 1
Gulietta Rear Wiper
« on: August 02, 2021, 10:20:23 PM »
Hello, my rear wiper blade stopped working so I had it fixed... well when I picked up car I noticed at first key turn rear wiper going on. I donít have it set on auto I always have wipers off and turn on manually when required.
They not just go on randomly and stop half way or odd angles. Not sure whatís going on, they worked perfect before they stopped working now fixed and itís all crazy going on random times.

Any ideas whatís gone wrong during repairs?

Craig_m67

  • Hero Member
  • *****
  • Posts: 1159
Re: Gulietta Rear Wiper
« Reply #1 on: August 03, 2021, 09:20:14 AM »

Any ideas whatís gone wrong during repairs?

Simple, It hasnít been repaired correctly.  Take it back, if you can. 
Otherwise order the correct replacement looms (2) and install them yourself.
Degree of difficulty is a 5

It is not possessed, itís not going to get better, they havenít fixed it.

Both original looms going into the hatch will eventually break, itís a known, documented problem that was addressed by Alfa everywhere else in the world, just not here because we really donít have any consumer protection for anything.

https://www.alfaworkshop.co.uk/alfa_Giulietta_boot_wiring_loom_replacement.shtml

https://www.shop4parts.co.uk/?name=store&op=Results&category=12&secondary=185&opts=212


No doubt, also available in Australia from local suppliers.  I donít remember who the recommended Melbourne people are, someone will be along in a minute to adviseÖ

« Last Edit: August 03, 2021, 09:29:44 AM by Craig_m67 »
'66 Duetto (lacework of doom)
'73 1600 GT Junior (ensconced)
'03 156 1.9JTD Sportwagon (daily driver)