Author Topic: Swapped out Dellorto 40 "L" problems  (Read 1329 times)

0 Members and 1 Guest are viewing this topic.

Altered

  • Newbie
  • *
  • Posts: 6
Swapped out Dellorto 40 "L" problems
« on: July 02, 2021, 07:36:49 PM »
Happy Friday to all..

Long and convoluted story, but the end result is that my 79 Alfetta sedan now has a pair of Dellorto DHLA 40 "L"s.

So......
Despite quite a bit of cold engine "back- popping", these carbs idle beautifully once warmed up and will reverse/take off quite smoothly, but as soon as you give them any non-dawdling throttle, the engine bogs down and refuses to deliver much if any go.
Yes classic lean situation..."maybe"...

Here's the odd thing.
If i remove the plastic jet inspection covers, all is good,,runs great.
So then I looked and discovered that the aftermarket air cleaner elements actually blocked the normal air feed to these jets.
(The Round hole next to main barrel)

Problems solved I thought.

But, as soon as I ran it without the offending air cleaners, (with jet inspection covers now refitted) the problem came back, albeit a bit different (I think..hard to tell).
Run it with both inspection covers and air cleaners removed the (similar) problem persists.

The take away is that the carbs seems to only work properly if the  main jets get their air supply solely via the removed inspection cover(s).!!
...If you add the air from where it should normally come...... things are not good again.

*Accelerator pumps all good.
*Carbs removed and thoroughly cleaned
*Refurbed intake mounts
*New inlet manifold.
*New carb to inlet manifold gaskets.
*Stock motor in perfect condition.
*Ignition advance (centrifugal) must be ok if it works fine with carb jet inspection covers removed.
*Fresher idle jet seals.
*Fuel pressure fine with previous carbs..and must be ok if it works fine with carb jet inspection covers removed.

These carbs were supplied to me by a local Alfa guy (who vouched for them as good and compatible). They ran acceptably (progression issue aside) on my 79  GTV even with shot idle jet seals, cracked inlet mount rubbers, and various other minor leaks and WITH THE BLOCKING AIR FILTERS IN SITU AND THE INSPECTION COVERS IN PLACE. !!!

What am I missing here.?

Its probably time for a paid visit to a local guru, but thought I'd throw the problem into the forum for a hopefully free fix . :o

Thanks..

carlo rossi

  • Hero Member
  • *****
  • Posts: 730
  • AROCA Member #: 8733
Re: Swapped out Dellorto 40 "L" problems
« Reply #1 on: July 03, 2021, 10:36:25 AM »
have you cleaned the little filters on  those covers
can you pull out the jets and tell me the numbers on them
carb1 then carb 2
current cars
red 83 gtv 2.0


previous cars
Red 76 1.2/1.5 alfasud ti
white 79 alfetta 2000
alfetta 74 1.8
escort Lotus twin cam
bikes
ducati 900 ss 1979
moto morini 3 1/2 sport 1975/6
Moto morini 3 1/2 valentini speciale 77 oh and a deltek rockhopper

Altered

  • Newbie
  • *
  • Posts: 6
Re: Swapped out Dellorto 40 "L" problems
« Reply #2 on: July 03, 2021, 01:36:37 PM »
Thanks for the reply Carlo

So both carbs have exactly the same jets.

Mains jet:
air correction 240
Emulsion tube 7772.10 (the profile shape differs from DHLA "Gs")
Jet 145


Idle Jets:
57
Holder has 1 row of 4 holes. (the profile shape also differs from DHLA "Gs")

Accelerator pump jets:
40

So jet wise, they are a magnitude different to bespoke 40 G's...BUT they have worked almost very well on pretty much the same year model engine .. (Disclaimer.... the GTV to which these were fitted MIGHT..MIGHT have  105 cams...another variable)

I have cleaned the little plastic covers mesh that feeds the starting-choke, and as far as I can see, the cardboard gasket is just that and not a filter of any sorts.

Would it have anything to do with the pressure of the supplied air originating from on top of the fuel chamber vs air supplied at the same level approximately on the side of the fuel chamber.? and thusly maybe fuel float level issue? just a wild hypothesis...as we know faults are usually something quite a simple solution.!!!




 



carlo rossi

  • Hero Member
  • *****
  • Posts: 730
  • AROCA Member #: 8733
Re: Swapped out Dellorto 40 "L" problems
« Reply #3 on: July 03, 2021, 01:44:53 PM »
your idle mix screws are they all equal and how many turns out from seated position
if not start at 4.5 turns raise your idle to around 1250 to 1500rpm and then turn all 4 half a turn anticlockwise until the engine revs drop
current cars
red 83 gtv 2.0


previous cars
Red 76 1.2/1.5 alfasud ti
white 79 alfetta 2000
alfetta 74 1.8
escort Lotus twin cam
bikes
ducati 900 ss 1979
moto morini 3 1/2 sport 1975/6
Moto morini 3 1/2 valentini speciale 77 oh and a deltek rockhopper

Altered

  • Newbie
  • *
  • Posts: 6
Re: Swapped out Dellorto 40 "L" problems
« Reply #4 on: July 03, 2021, 03:58:22 PM »
Haha..Thanks again..

Think I predicted your next input.

I went back to basics..
And like you suggested i wound all mixture screws in fully (taking note of how many turns, just incase i need to reverse, they were all only about 2.5-3.5 turns)

Wound them all out 4 turns..
Test drive..Huge improvement..Drive through the flat hesitation and she came alive.
A further half turn better still.. Almost back to "usable" as the were on the GTV.

On trying to further experiment, discovered that mixture screw no 2 is a ring in, and proving very difficult not only to wind out further, but very tricky to remove altogether..So have removed the left carb again for in shed night fettling.

Also noticed that my new carb gaskets were slightly damp with fuel..I thought they were too thin from the get go..So I'll double them all up or see if I can get some thicker softer ones.



 

fazersix

  • Jr. Member
  • **
  • Posts: 45
  • AROCA Member #: 7155
Re: Swapped out Dellorto 40 "L" problems
« Reply #5 on: July 11, 2021, 06:03:31 PM »
A jammed mixture screw forced me into a carb rebuild, on my DHLA40 'G'.  I had to cut the boss down with a dremel to re-slot the screw to get it out. Carlo gave me great advice on jetting and mixture setting and after the rebuild I synchronised the carbs and thought that I had set the mixture screws ok
But I kept getting a random fouled plug on #2. Further reading pointed towards mixture so i bought a colortune - now more plug fouling! This may help you also!

Altered

  • Newbie
  • *
  • Posts: 6
Re: Swapped out Dellorto 40 "L" problems
« Reply #6 on: July 13, 2021, 05:34:14 PM »
Thanks Fazersix for that.

Happy news, and with thanks to support on here, the sedan is running great again.
Advice on here helped me break some stupid assumptions.

So as much as these carbs ran okish on the GTV, it didnt mean that they'd run similarly on an "identical" engine.

Visiting the idle mixture screws to rich them up, I discovered that not one, but 2 had screws unable to adjust out very far (ie they had partially "seized"  and could not be removed.
Fettling and dremelling I got one out cleanly. Not so the second ..

Ended up having to drill it out..ARRGH!!  And as careful as I was i lost the 0.5 mm fine thread.
Local guru suggested that it would be acceptable to have this one screw modified to suit a WEBER idle mixture needle.
He said they don't need to be THAT precise.
This guy really knows his stuff, but I couldn't afford to get him to do the mod.

Armed with that flexibility, I sourced a much longer idle mixture screw needle and inserted a nylon bush in the top of the mount, and self tapped the thread using the ring-in idle mixture needle.

Then, after quite a bit of trial and error adjustment (including advancing the timing 5-10 degrees), and balancing the carbs by ear the sedan is now singing the right tune..
Tested hot and cold.. All seems fine..
Not sure how it will handle Summer and traffic, as this seems to be the real trial of the overall setup.
Funny thing is that despite the substitute needle have twice the thread pitch, it ended up needing the same number of turns as that of the other 3 (original needles).

Thanks again Peeps for the help.