Author Topic: 2015 giulietta QV electrical faults  (Read 4298 times)

0 Members and 1 Guest are viewing this topic.

Ando117

  • Newbie
  • *
  • Posts: 6
2015 giulietta QV electrical faults
« on: February 16, 2016, 06:23:12 PM »
Hi guys,
Sorry this is a bit of a long one.
Writing to see if anyone else has/ever had the same problem im having. I have only had my Giulietta for about 6 months and have around 13000km on the clock.
2-3 weeks ago i was driving my G home at about 11pm on a dark country road when i noticed my left rear indicator light wasn't flashing and that the dash blinker indicator ( < > ) was flashing rapidly indicating that i had indeed lost that a light it took some further 30 seconds for the warning light to appear. I pulled over to consult the manual to check this wasnt anything nastier and continued on my way. In this time all other indicators stopped working so i tried to get her home. As i continued i saw the brake lights drop out and about 10 seconds later right as i had hit a large sweeping corner i completely lost all front lighting luckily i was already on the brakes and there was just enough moon light to get me somewhere safe. While this was happening i lost internal lighting and guages however the radio screen stayed on...
I pulled over switched off the car and re started to find everything working except the left rear indicator fortunatly i was only a minute away from home at this stage and slowly took her home without any further faults. The next morning rang the local dealership and was told to get it in right away. They diagnosed that it maybe just faulty wiring on the indicator that caused the problem and they had taken the lights apart to check the wiring and it looked fine...
Today started the car up from work and drove about 5 minutes before the same issue started again so we are back at the dealer thursday.. hopefully with a fixed issue.

lombardi

  • Hero Member
  • *****
  • Posts: 552
  • alfa romeo con stile
  • AROCA Member #: 7655
Re: 2015 giulietta QV electrical faults
« Reply #1 on: February 18, 2016, 05:20:31 PM »
How frustrating , at least still under warranty , thought the Marchionne era Alfa's would be more sorted in the electrical department. I have owned my new Giulietta qv manual for about 4 months and can say no issue as yet , just one annoying issue with the Ipod classic 7th generation ipod and the connectivity , very slow to recognise the ipod and at times fails to display album covers and sometimes does not connect at all plus on occasion song changes but display shows previous song info and then the other day just switched automatically to radio . In my previous alfa i had installed a kenwood set up and had none of this problem , anyhow back to the dealer on monday to hopefully fix this issue, am not confident though, as this is the 2nd trip to the dealer with this same issue.........
forza lazio,viva l'alfa

Current Alfa=
 
Giulietta 2015 QV manual Ghiaccio

1974 Spider series 2 ,carabinieri blu





Previous Alfas=


33x4 1985 wagon
33 ti 1985
156 sportswagon manual red
Alfetta sportiva 1981 red
166 silver 1999