Author Topic: 159ti auto issues  (Read 3529 times)

0 Members and 1 Guest are viewing this topic.

wombat

  • Newbie
  • *
  • Posts: 4
  • AROCA Member #: 3973
159ti auto issues
« on: November 28, 2015, 08:31:31 AM »
I have a 2010 159ti wagon auto, the 2.4 diesel version but it has had some recent issues with the auto box; when I set off it starts in 1st gear revs high before selecting 2nd then finally selects D. it will then run normally until I stop put the selector to P and kill the engine. now it starts flashing the P and beeping preventing me from removing the key fob unless I remove the emergency key and release it.
the local dealer has looked at this at it's recent 100,000km service and tried to adjust the linkage cable without success they are now looking for a price to order a new one. Sadly I do not have a lot of confidence with this dealer as I have had a couple of issues in the past so I was wondering if anyone has any experience of similar issues with this gear box and can either give me confidence that I will not be wasting my money or has an alternative solution to suggest.
(by the way I live in country Victoria so there is no other dealer or Alfa specialist around as far as I know).
Now:
Giulietta Veloce
Alfetta GLC
Alfa GTV6 (still in UK)
Past:
159 Sportwagon Ti 2.4JTD
Suds (2 both 1.5 supers)
33 (1.7 Veloce)
155 (Wide Body 2.5 V6)
164 (2.0 TS)
156 (1.8TS)

Australia

  • Sr. Member
  • ****
  • Posts: 321
Re: 159ti auto issues
« Reply #1 on: November 28, 2015, 11:10:16 AM »
I have a 2010 159ti wagon auto, the 2.4 diesel version but it has had some recent issues with the auto box; when I set off it starts in 1st gear revs high before selecting 2nd then finally selects D. it will then run normally until I stop put the selector to P and kill the engine. now it starts flashing the P and beeping preventing me from removing the key fob unless I remove the emergency key and release it.
the local dealer has looked at this at it's recent 100,000km service and tried to adjust the linkage cable without success they are now looking for a price to order a new one. Sadly I do not have a lot of confidence with this dealer as I have had a couple of issues in the past so I was wondering if anyone has any experience of similar issues with this gear box and can either give me confidence that I will not be wasting my money or has an alternative solution to suggest.
(by the way I live in country Victoria so there is no other dealer or Alfa specialist around as far as I know).

Take your car an hour  up the road to an indy in Melbourne or contact one of them to find out who is a specialist Alfa auto transmission specialist.

ANG156

  • Sr. Member
  • ****
  • Posts: 346
Re: 159ti auto issues
« Reply #2 on: December 04, 2015, 06:26:20 PM »
The 159 gearbox is made by aisin who also manufactured gearboxes for the ve commodore. There has been known issues with this gearbox across both marques but nothing an automatic transmission specialist would be able to repair. Only difference is the transmission specialist will not have access to the Alfa software.

My uncle was a Holden mechanic up to 6 months ago before retiring and it was quite common that the autoboxes used to suffer from sticky solenoids which cause the cars to rev randomly in between gears. Gm at the time asked dealers to drive cars in sport tronic mode flicking gears like a manual. This cured most problems with the cars. Yours may be a bit different as there sounds like there is an actual error with the box/ software but I would give it a go.