Author Topic: Hey all!  (Read 2702 times)

0 Members and 1 Guest are viewing this topic.

Alfa156Melb

  • Newbie
  • *
  • Posts: 10
Hey all!
« on: April 28, 2008, 03:33:57 PM »
Hi All, just bought a 2003 156 upgrade - and love it!  It has some of the common problems like a creaking upper wishbone, and the engine tenp seems to be running a little low (60 Degrees!) but otherwise its just fantastic.

I can't believe i was considering a BMW! in fact, having had a number of Beemers before, I doubt ill go back to them - Alfa's for me from now on :)

Anth73

  • Sr. Member
  • ****
  • Posts: 261
Re: Hey all!
« Reply #1 on: May 01, 2008, 08:16:04 PM »
Welcome aboard! What engine / transmission combination did you end up getting?

The low engine temp will be due to the thermostat not fully closing. You can replace it yourself in under an hour if you have some basic tools and some mechanical inclination.

The creaking wishbones are another common "feature". Not really worth changing unless they are driving you mad. Get them checked by an Alfa specialist to be sure. Damon at Lance Dixon has looked after me very well...highly recommended.

Alfa156Melb

  • Newbie
  • *
  • Posts: 10
Re: Hey all!
« Reply #2 on: May 02, 2008, 08:33:17 AM »
Hi Anth,

I have the JTS 2 litre with Selespeed. I know the selespeed gets a lot of flack, although I think they mostly fixed the problems from '03 onwards.. but its just so much fun!

I'm actually planning on calling Damon today - he's mentioned everywhere in this forum - thats gotta say something.

Dave.

Victor Lee

  • Sr. Member
  • ****
  • Posts: 495
  • AROCA Member #: 944
Re: Hey all!
« Reply #3 on: May 02, 2008, 09:39:29 AM »
Dunno if he's back from his honeymoon yet ... ;)
Current Alfas:  Alfa 159 3.2lt Q4; Alfetta GTV6; ES30 SZ (all V6s!);  2015 4C LE.
Past Alfas:      '02 156 2.0lt JTS; '84 Alfetta GTV6; '82 Alfetta GTV 2.0; '85 Alfa 33 1.5 GCL single carb